GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Uploading a report is slow, the skipping of existing files does not...

Click to view RSS...
Author when I was uploading an updated report to the Genopro server, it was very fast because the program skipped the "unchanged" files. This no longer works.
Posted Friday, September 28, 2007 - Post #19335
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Important Contributors
GenoPro version: 3.0.0.7

Last Login: Friday, October 23, 2020
Posts: 213, Visits: 4,463
Until a few month ago, when I was uploading an updated report to the Genopro server, it was very fast because the program skipped the "unchanged" files.

Recently, I've noticed that when I update a report, even with a small modification of one individual, I Have to upload again the entire files and it takes a lot of time.

Is this problem exists only on my report or is it a general problem?

Edited: Friday, September 28, 2007 by GenoProSupport

Posted Friday, September 28, 2007 - Post #19336
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Gamma
Moderators
Administrators
FamilyTrees.GenoPro.com
Customers
GenoPro version: 3.1.0.0

Last Login: Wednesday, October 7, 2020
Posts: 952, Visits: 10,075
I can confirm you that this is a general issue (no matter the source file and the skin, most of all generated files are always re-uploaded), the server code hasn't change but probably something has been broken in GenoPro.

We will investigate, and fix the issue.

Posted Friday, September 28, 2007 - Post #19338
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 11:56 AM
Posts: 4,597, Visits: 22,223
beraha (9/28/2007)
Until a few month ago, when I was uploading an updated report to the Genopro server, it was very fast because the program skipped the "unchanged" files.

I can confirm there is a problem where all the files are uploaded.  Somehow my caching detection algorithm is no longer working and I am working on a fix.  By looking at the code, I suspect this bug has been there for more than a year.  I am curious to know which version of GenoPro you remember to be "very fast" when uploading a report to http://familytrees.genopro.com/.

Edited: Friday, September 28, 2007 by GenoProSupport

Posted Friday, September 28, 2007 - Post #19341
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Important Contributors
GenoPro version: 3.0.0.7

Last Login: Friday, October 23, 2020
Posts: 213, Visits: 4,463
GenoProSupport (9/28/2007)
I can confirm there is a problem where all the files are uploaded.  Somehow my caching detection algorithm is no longer working and I am working on a fix.  By looking at the code, I suspect this bug has been there for more than a year.  I am curious to know which version of GenoPro you remember to be "very fast" when uploading a report to http://familytrees.genopro.com

Well. I am thinking that this bug was there for about 6 month (Not sure), but if you say it was for more then a year, it seems that time goes faster then you feel. Tongue:

I am curious, how could it be that no one else found this bug since it was very annoying to upload each time the entire report.

I like to use  "Genopro Familytree server", since it's much faster then using  FTP.

However, every time I want to delete a single file or a picture, I have to delete the entire publication and upload it all over again. Somehow, I can't access my account via FTP and delete files manually.  

Edited: Saturday, September 29, 2007 by beraha

Posted Friday, September 28, 2007 - Post #19342
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 11:56 AM
Posts: 4,597, Visits: 22,223
I have fixed the bug.  You were right, the bug was introduced a few months ago, with GenoPro version 2.0.0.6 to be more exact.  I was searching the code in the report generator, but the problem was in the XML parser.   I upgraded the XML parser to keep comments because I thought the comments would be useful when translating/localizing GenoPro.  I forgot to upgrade the parser to skip comments when searching for the root node.  As a result, the report generator was unable to find the root node <GenoProCache> and therefore was not performing any caching, thus uploading the entire report each time.  The file GenoProCache.xml contains information about previously published report, and this file is used to compare what was generated with what was previously generated.

We will make a small update about this soon.

Edited: Friday, September 28, 2007 by GenoProSupport

Posted Wednesday, October 24, 2007 - Post #19631
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.0

Last Login: Friday, May 8, 2020
Posts: 69, Visits: 728
Hello!

So, May I ask when it will be possible to upload reports correctly without unchanged files?

Because now I am using the 2.0.1.1 and there is no possibility of such thing.

If i check the option to "continue report" It works and I notice that it skips the unchanged files and stops for a little while during report for the writing of the new ones but no change appears at the report after uploading. So I have to upload it complete...

Posted Thursday, October 25, 2007 - Post #19634
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 11:56 AM
Posts: 4,597, Visits: 22,223
I fixed the bug, however GenoPro is in an intermediate format.  I changed the file format to support new type of objects, such as secrets (secret affair, secret child, secret job, secret abuse/violence) and a other changes, such as a field for Current Location, Immigration and Income.

I just released this version to Monica McGoldrick yesterday and I am waiting for more feedback from the Multicultural Family Institute before including those changes permanently in GenoPro.  Monica is currently in Brazil giving a conference, however she already tried the product.

I can give you a link to the special version for Monica which has the fix.

Edited: Thursday, October 25, 2007 by GenoProSupport

Posted Thursday, October 25, 2007 - Post #19635
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.0

Last Login: Friday, May 8, 2020
Posts: 69, Visits: 728
Thank you very much for the quick reply!

Yes I will highly appreciate if you give me (to e-mail) link to the fixed variant!

Posted Thursday, October 25, 2007 - Post #19636
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 11:56 AM
Posts: 4,597, Visits: 22,223
Mantreat (10/25/2007)
Yes I will highly appreciate if you give me (to e-mail) link to the fixed variant!

You are welcome to try the version http://www.genopro.com/download/InstallGenoProMonica.exe.

I would recommend installing this version in a different folder and use it only to generate reports.  The file format has been changed and may change too.  By the way, many family relationships have been removed in this version, so your report may be missing some of the family relationships.

Posted Wednesday, June 4, 2008 - Post #21816
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.0

Last Login: Friday, May 8, 2020
Posts: 69, Visits: 728
Hello!

Probably there is the same problem like it was at the beginning of this topic...

The program during report updating shows that new pages and pictures are uploading but thereare no updated pages and pictures at the report after opening of the updated report...

Maybe I didn't notice someting...?



Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse