GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Inserting family tree into a MS-WORD document

Click to view RSS...
Author
Posted Saturday, December 11, 2010 - Post #27136
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
GenoPro version: 2.0.1.6

Last Login: Thursday, December 30, 2010
Posts: 2, Visits: 7
I have a tree I would like to insert as an image/object into a MS-WORD document. What is the best option? All I can come up with is to create a .PDF image but ideally, for clarity, I would like to create .jpeg image.
Posted Saturday, December 11, 2010 - Post #27137
Grand Master

Grand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.3

Last Login: 1 hour ago
Posts: 1,475, Visits: 26,801
Use the export option and create a metafile. Convert this - I use the freeware IrfanView
Posted Saturday, December 11, 2010 - Post #27138
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.0.1.3

Last Login: 2 days ago @ 2:39 PM
Posts: 4,427, Visits: 21,761
You can always use the Copy & Paste.  To select the entire genogram, press Ctrl+A (Select All), then Ctrl+C (Copy) and go to Word and press Ctrl+V (Paste).
Posted Friday, October 23, 2015 - Post #36035
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Gamma
GenoPro version: 3.0.0.3

Last Login: Friday, October 23, 2015
Posts: 1, Visits: 5
Thanks! This is great. The genogram is much clearer than just copying and pasting as others have suggested.
Posted Sunday, March 04, 2018 - Post #38583
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Gamma
GenoPro version: 3.0.1.2

Last Login: Saturday, May 12, 2018
Posts: 1, Visits: 4
When I copied and pasted the genogram, it pasted very tiny. How can I make it bigger?
Posted Monday, March 05, 2018 - Post #38585
Forum Guru

Forum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum Guru

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:21 AM
Posts: 189, Visits: 1,047
  1. Open your tree in GenoPro, with the specific portion of your tree you want to insert visible on the screen.  Leave Genopro running ... ie, do not minimize it.
  2. Open your Word document.  I assume you have Word 2007, 2010 or a more current version.
  3. Go to the Insert Tab on your Ribbon ... then Screenshot.
  4. Capture the Screenshot of your GenoPro tree, and modify as required.  Here are some notes from the Help in Word.

Word




 Note    Only one screenshot at a time can be added. To add multiple screenshots, repeat steps 2 and 3 below.




  1. Click the document that you want to add the screenshot to.
  2. On the Insert tab, in the Illustrations group, click Screenshot.Office 14 Ribbon

  3. Do one of the following:
    • To add the whole window, click the thumbnail in the Available Windows gallery.
    • To add part of the window, click Screen Clipping, and when the pointer becomes a cross, press and hold the left mouse button to select the area of your screen that you want to capture.If you have multiple windows open, click the window you want to clip from before clicking Screen Clipping. When you click Screen Clipping, the program you are working in is minimized and only the window behind it is available for clipping.




Tip  After you add the screenshot, you can use the tools on the Picture Tools tab to edit and enhance the screenshot.
Posted Sunday, December 30, 2018 - Post #39140
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
GenoPro version: 3.0.1.4

Last Login: Monday, February 04, 2019
Posts: 2, Visits: 17
I used to be able to copy a set of individuals from a Genopro map and then paste into MS Word.  This would place a very clear image into Word.  Unfortunately, as of Genopro version 3.0.1.4, pasting into Word simply pastes a blank box.  I can take a Windows snippet or MS Word screen clipping, but those pasted images are too fuzzy.  When pasting so many individuals into a document, images with fuzzy individuals and names is unreadable.  Has anyone else had luck pasting into the current version of Word from Genopro 3.0.1.4?  Is there a good way to uninstall and revert back to the previous version and not corrupt my Genopro map?

Tags:
Posted Friday, January 04, 2019 - Post #39157
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.0.1.3

Last Login: 2 days ago @ 2:39 PM
Posts: 4,427, Visits: 21,761
To my best knowledge, the code to copy a family tree into the clipboard was written in 1998 (20 years) ago and has been running unchanged.  What has changed is many people are using Office 365 which has issues with the copy and pasting of metafiles from the clipboard.  If you use GenoPro 2018 and paste with an older version of Word, or any other program supporting the pasting of metafiles, you will see that it is working as before.

What you can do is try to export your family tree to a metafile (Menu -> File -> Export -> Metafile).  Then, import the metafile as a picture into your Word document.
Posted Monday, January 07, 2019 - Post #39168
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie


Gamma
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 2:04 PM
Posts: 9, Visits: 77
I did some testing of GenoPro's 2018 (ver 3.0.1.4)  copy/ paste functionality with small and HUGE genograms.

Copy paste works fine with:
Windows 7 and Office 2007
Windows 10 with Office 2007
Windows 10 with Office 365 up to date.
Windows 7 and MS Paint
Windows 7 and Photoshop CS (most recent)

That said, I did find some issues with copy/paste on Windows 10, particularly NON Office products.
When using Select All and copying to the clipboard.  GenoPro creates an Enhanced Metafile.
Microsoft apparently broke something on Windows 10 and now by default when you paste, Windows will treat it as a Windows Metafile and not as an Enhanced Metafile, so the paste behaves erratically missing many elements.
When I pasted to Word, Word DID detect the Enhanced Metafile correctly, regardless if it was the latest and greatest or an older version.

So my suggestion is that in MS Word you pick "Paste Special" and make sure that you select Enhanced Metafile.  As mentioned by Legendary Master, that particular part of the code has not changed, so I don't think that going back to and older version would resolve it.

If Paste Special does not resolve your issue, it would be useful to tell us:
1) What version of Windows you have
2) What version of Word you have
3) What version of GenoPro did you use before you updated to 2018 (3.0.1.4)

Regards

Edited: Monday, January 07, 2019 by GenoPro dev2
Posted Saturday, January 12, 2019 - Post #39179
Forum Guru

Forum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum Guru

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 2:29 PM
Posts: 192, Visits: 2,762
I use w10 and office365
As far as I understand, the problem arises from the position of point 0 (Zero) on the Genomap: if the point x = 0, y = 0 is not at the center of the selection made, we copy and paste an empty or otherwise decentralized part of the screen!
This happens. But I do not know why.
Therefore, if the genomap to copy is small:
1 - click Tools / Balance tree at origin
2 - select and copy
3 - pastes in Word or other

If the genomap is large, select and copy the relevant sector, and paste into a new genomap.
Then repeat the previous operations 1, 2, 3.
This also applies to copy genomaps, e.g., in IrfanView to create JPG images or other.
I hope the suggestion solves some problems.

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse