GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Report Generator 2014.04.10

Click to view RSS...
Author [RESOLVED] pictures.htm is missing from report folder
Posted Saturday, April 19, 2014 - Post #33483
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Thursday, July 4, 2024
Posts: 472, Visits: 3,212
When generating an English Narrative Report version 2014.04.10 the pictures.htm file seems to be missing.

So, when clicking on "Albert Ackermans (b.1910)" in the snap shot below, the picture will appear.
But when clicking on "PIC05" - which should bring up the picture gallery - an error message is produced.



Tests with a previous version (2013.08.12) run OK.  Here the pictures.htm file is generated.

Be sure to use an empty destination folder when trying this out.

Sorry to spoil your Easter weekend Ron.


Edited: Monday, May 5, 2014 by Nand
Posted Wednesday, April 23, 2014 - Post #33501
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Thursday, July 4, 2024
Posts: 472, Visits: 3,212
Would it be possible for someone else to confirm this behaviour?

I have tested it again yesterday on a Windows 7 system, using a fresh installation of the English Narrative Report and got the same results: no picture gallery generated.
Posted Thursday, April 24, 2014 - Post #33509
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 3:02 PM
Posts: 281, Visits: 12,048
Yes, I see it too.
Posted Monday, May 5, 2014 - Post #33569
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 9:12 AM
Posts: 3,369, Visits: 25,827
Sorry for the delay in looking in to this. 

With so many changes to the Narrative over previous months I had forgotten a change I made in this area.  

The Thumbnails tab of Config Params has a Show Gallery setting that is off by default.  The gallery page can huge and therefore take an age to load.  Many users do not seem to understand bandwidth and upload photos straight from umpteen megapixel digital cameras without resizing.  This was my attempt to force users to use thumbnails if they wanted to include a gallery page.  

I will look into modifying the skin to take account of this when generating the picture index page (toc).


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Monday, May 5, 2014 - Post #33570
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 9:12 AM
Posts: 3,369, Visits: 25,827
Further to my previous post, I do not think it is sensible to load the whole picture galley when a photo is clicked on the index.  It would be much better if just that single photo was displayed, as happens when a thumbnail image is clicked on an Individual's page.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Monday, May 5, 2014 - Post #33577
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Thursday, July 4, 2024
Posts: 472, Visits: 3,212
Yes, that's it.  I completely missed the "Generate Picture Gallery" parameter in the "Thumbnail" tab.

No problem with removing the load and display of the complete gallery when a single picture is clicked. 

What about adding a third menu entry at the same level of the "Individual" and "Family" pictures level?  The presence of this menu entry would then depend upon the "Generate Picture Gallery" parameter setting.



Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse