GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Error with genomap.svg

Click to view RSS...
Author
Posted Tuesday, August 01, 2017 - Post #38248
Forum Guru

Forum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum Guru

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Tuesday, October 31, 2017
Posts: 163, Visits: 844
Publishing report to http://familytrees.genopro.com/xxx/ToDentroMas/
  Connecting to server familytrees.genopro.com...
Cloning document Dentro...
Opening configuration file Config.xml for skin '\{EN} Narrative Report\*  (2016.07.16)'...
Loading Dictionary.xml...
[0.00] Processing template 'bootstrap.vbs'...
[0.64] Processing template 'Code\init.htm'...
Report Skin version 2016.08.11
  **** with modifications ****
Report Language code 'EN' Dictionary version '2016.07.16'
To disable display of parameter settings, tick the box under 'Options' tab of 'Generate Report' dialog.
Checking thumbnails status
[37.15] Processing template 'Code\style.css'...
Applying theme 'GreenLeaf_2'
Copying files from default theme
Copying files from selected theme
[57.17] Processing template 'Code\header.htm'...
[57.18] Processing template 'Code\footer.htm'...
[57.21] Processing template 'Code\cover.htm'...
[57.25] Processing template 'Code\introduction.htm'...
[57.26] Processing template 'Code\toc.xsl'...
[57.28] Processing template 'Code\index.html'...
[57.64] Processing template 'Code\default.htm'...
[58.03] Processing template 'Code\toc_individuals.htm'...
[58.78] Processing template 'Code\toc_families.htm'...
[59.18] Processing template 'Code\toc_charts.htm'...
[59.54] Processing template 'Code\toc_contacts.htm'...
[60.10] Processing template 'Code\toc_places.htm'...
[60.48] Processing template 'Code\toc_sources.htm'...
[60.90] Processing template 'Code\toc_names.htm'...
[61.25] Processing template 'Code\genomap.svg'...
Error at line 1264, position 1 (Code\genomap.svg) generating 'genomap.svg': Subscript out of range: '[number: 0]'
    Microsoft VBScript runtime error 800A0009
   
Just got this error.  Seemed to work fine yesterday.  Not sure what changed, except for an unsuccessful attempt to generate a GEDCOM file, and adding more people to the tree.
Posted Tuesday, August 01, 2017 - Post #38250
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 10:15 PM
Posts: 2,520, Visits: 17,929
This seems to be caused by the presence of a Shape or Household in your ,gno without any visible points.  Don' t know how you would arrive at a Shape with no points but I have now discovered it is possible to have an empty 'pointless' Household. Simply create a household of say two individuals and then exclude each individual in turn to leave an empty invisible household.  This is probably a GenoPro bug as I think empty households should be removed automatically.   
 
Anyway, use Table Layout / Households and see if you have any households with no entry in the 'Position Points' column.  If so delete those entries and rerun the report generation.

I will amend the skin template to check for this condition in future.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Wednesday, August 02, 2017 - Post #38255
Forum Guru

Forum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum GuruForum Guru

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Tuesday, October 31, 2017
Posts: 163, Visits: 844
Thank you .. found the culprit... problem solved.


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse