GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Descendant Tree charts

Click to view RSS...
Author Mechanism seems broken
Posted Monday, October 15, 2018 - Post #39004
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:49 PM
Posts: 352, Visits: 2,277
GenoPro 3.0.1.4 + Skins Update Package 2018-10-01 + Code update package 2018-10-13.

I found it strange that there was no reaction when clicking on any of the entries of a Descendant Tree Charts list until I noticed the URL at the bottom left corner of my FireFox browser window:






Should that not read tree=ind00004.js



Posted Wednesday, October 17, 2018 - Post #39012
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 8:38 PM
Posts: 2,659, Visits: 19,338
Yep, you are correct. looks like I updated the standalone HTML Descendant Tree report a while back, probably to overcome some more 'same origin' security issues in Chrome, but forgot to update the Narrative Report skin as well.  

I have included a correction in the Skins update http://support.genopro.com/Topic38889.aspx

I also noticed that non-local pictures (e.g. http URLs as in HP) were not displayed so this too has been fixed.  

Have also included your latest NL-BE kit in that update.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Thursday, October 18, 2018 - Post #39017
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:49 PM
Posts: 352, Visits: 2,277
Status quo.

I have removed all old skins, just to be sure, and unpacked the contents of "2018-10-17 SkinsUpdate.zip".
After generating a report using the English Narrative Report and the English Descendant_Tree skin the results are the same.
No chart is displayed and the link at the bottom of the window still contains a reference to the xml file.

This was an out-of-the-box test.  I just unpacked an ran the generator.  No customisations whatever.

Posted Thursday, October 18, 2018 - Post #39018
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 8:38 PM
Posts: 2,659, Visits: 19,338
I'll check that. I was having some issues with DropBox deleting my files. Maybe I didn't restore the correct versions.

DropBox really doesn't play nice when there is a junction point i.e. the linked Code folder in the Narrative Report.  I decided to set DropBox selective sync and tell it not to sync the linked Code folder, but it then went on to delete some files from by Narrative Common\Code folder as well !!


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Friday, October 19, 2018 - Post #39021
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 8:38 PM
Posts: 2,659, Visits: 19,338
I have double checked and it is working fine for me and Util.vbs has the fix in it.  (scripts.js was missing from update but that had not changed. new update has it)

Just wondering it is a browser cache issue with you?


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Friday, October 19, 2018 - Post #39022
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:49 PM
Posts: 352, Visits: 2,277
We're getting closer.

If I select the "charts" menu and click on a name in this list, nothing seems to happen.

However, if I click on the tree icon following the individual's name, it works.  The descendant tree chart is displayed.

There must be a conflict of parameters somewhere.


Posted Friday, October 19, 2018 - Post #39023
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:49 PM
Posts: 352, Visits: 2,277
By the way, the "Descendants Tree Chart - Parameter Settings" interface has the same problem as the one mentioned in the Cannot load saved profile topic.

If I select a non-default profile, the screen refreshes and reverts to the "defaults" profile, as soon as I hit the [ Load ] button.
Posted Friday, October 19, 2018 - Post #39024
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 8:38 PM
Posts: 2,659, Visits: 19,338
Yes I have only fixed half the problem.  I had completely forgotten about the Descendants Chart Index. Blush

Thank you for your patience, I am going to blame it on another 'senior moment'. 

I'll look at the parameter settings issue too.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Saturday, October 20, 2018 - Post #39030
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 8:38 PM
Posts: 2,659, Visits: 19,338
May be 'third time lucky' with today's skins update.

Also noticed that with the descendants chart in the Narative Report the frame maximise/restore icons were not addressed correctly so I fixed that too. Plus some cosmetic changes to config params 


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Saturday, October 20, 2018 - Post #39031
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Yesterday @ 10:49 PM
Posts: 352, Visits: 2,277
Thank you.  I'll give it a try today.  First need to do some cleaning-up.  Looks as if I have more versions than files.


The people I'm writing about are all dead.  So they don't mind waiting.


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse