GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




How I can add photo to main page?

Click to view RSS...
Author How I can add photo to main page?
Posted Thursday, March 21, 2019 - Post #39550
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202
Hi!
I can not add main photo to main page familytrees.genopro.com/alperovich_vremenno

When I create report in last version
I write path to my photo


<?html?><center><img src="pictures/AzbeliOronoviDavidovi.jpg " width="50%" ></center><?html?> ,

but this photo not load to familytrees.genopro.com/alperovich_vremenno/default.htm

Why?
see please result of report generation ( fail 2)
Help please A.S.A.P

fault report.jpg (6 views, 148.97 KB)
fault report1.jpg (3 views, 143.91 KB)
Posted Thursday, March 21, 2019 - Post #39551
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Yesterday @ 12:21 PM
Posts: 2,810, Visits: 20,489
Try src=“media/AzbeliOronoviDavidovi.jpg”

Also the .jpg must be referenced elsewhere in your .gno under any object’s Picture tab so that GenoPro knows the source file to copy it from.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Thursday, March 21, 2019 - Post #39552
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202
not work <?html?><center><img src="media/AzbeliOronoviDavidovi.jpg " width="50%" ></center><?html?>

Need create folder "media" with photo?
 

Now photo locate in C:\genealogija\images\AzbeliOronoviDavidovi.jpg
Posted Thursday, March 21, 2019 - Post #39553
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202
may be need -> see photo

fault report2.jpg (2 views, 180.71 KB)
Posted Thursday, March 21, 2019 - Post #39556
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Yesterday @ 12:21 PM
Posts: 2,810, Visits: 20,489
If you are using the Narrative Report skin from an earlier version of GenoPro then src="pictures/AzbeliOronoviDavidovi.jpg" is correct. However for GenoPro 2018 it should be src="media/AzbeliOronoviDavidovi.jpg"

But for both versions of GenoPro you must ensure that the picture is copied to the report folder by GenoPro when the report is generated.  This is achieved by having a reference to the same photo in a "Picture" tab of any object.

e.g. 

http://support.genopro.com/Uploads/Images/9187af04-9c28-4b8b-8931-87e5.png


Note that the object does not need to be a Label, it can be any object with a Picture tab, e.g. Individual, Family, Occupation, Education, Social Entity etc.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Thursday, March 21, 2019 - Post #39558
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202
Hi!
Unfortunate I did all, but do not work correctly again!
See please all photos:
- fault report3.jpg
- fault report4.jpg
- fault report5.jpg
Please explain more better!

http://support.genopro.com/Uploads/Images/63d6e3f0-38d0-4fde-9ffb-29cc.jpg


http://support.genopro.com/Uploads/Images/c02bf31a-5003-4404-b18d-40a3.jpg

http://support.genopro.com/Uploads/Images/d0863fbe-dd8c-4771-a5fd-e5fd.jpg


fault report3.jpg (2 views, 423.93 KB)
fault report4.jpg (1 view, 331.71 KB)
fault report5.jpg (1 view, 438.59 KB)


Edited: Thursday, March 21, 2019 by 164514
Posted Thursday, March 21, 2019 - Post #39559
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202

http://support.genopro.com/Uploads/Images/458c7844-fbdf-44d0-b0a2-55e0.jpg


and this is in last, correct version
http://familytrees.genopro.com/jurela/alperovich/































fault report1.jpg (2 views, 143.91 KB)

Edited: Thursday, March 21, 2019 by 164514
Posted Thursday, March 21, 2019 - Post #39560
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Yesterday @ 12:21 PM
Posts: 2,810, Visits: 20,489
I stated in my earlier post: 

If you are using the Narrative Report skin from an earlier version of GenoPro then src="pictures/AzbeliOronoviDavidovi.jpg" is correct. However for GenoPro 2018 it should be src="media/AzbeliOronoviDavidovi.jpg"


You are using GenoPro 2011, i.e. an earlier version of GenoPro than GenoPro 2018, therefore you should use src="pictures/10.semja_Aberovich_i_Borja.gif" and NOT src="media\10.semja_Aberovich_i_Borja.gif"

In your last correct report the photo appears to have been copied to the images folder of the  Report skin before the report was generated and has been referenced as images/10.semja_Aberovich_i_Borja.gif.  This is an alternative way of acheiving a similar result, rather than using a Label or other object to reference the image/photo.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Thursday, March 21, 2019 by genome
Posted Friday, March 22, 2019 - Post #39562
Forum Writer

Forum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum WriterForum Writer

Customers
GenoPro version: 3.0.1.0

Last Login: Thursday, July 11, 2019
Posts: 59, Visits: 202
Dear Master!
Thanks, one photo OK, but second photo do not view!

<?html?><center><img src="pictures/10.semja_Alperovich_i_Borja.jpg " width="20%" ></center><?html?>
<?html?><center><img src="pictures/nasha semja 2016.jpg " width="20%" ></center><?html?>


http://support.genopro.com/Uploads/Images/16cfbe21-dc72-4a16-ad71-9144.jpg

Both photo in file genopro:

http://support.genopro.com/Uploads/Images/7cfe7d66-9b06-4e70-9dc0-2847.jpg

Both photos in folder Report


http://support.genopro.com/Uploads/Images/89cbd7de-916f-42b8-ba51-f67c.jpg


Where is my FAULT?
Best regards
Juri
Posted Friday, March 22, 2019 - Post #39565
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Yesterday @ 12:21 PM
Posts: 2,810, Visits: 20,489
Ok, I did not want to complicate things too much earlier but now that you are using a filename with spaces I need to tell you that sometimes GenoPro adjusts the name of the file when it is uploaded.  w00t

Therefore src="pictures/nasha semja 2016.jpg" needs to be src="pictures/nashaSemja2016.jpg"

This may help:

http://support.genopro.com/Uploads/Images/ec05150a-bf84-45a0-b92c-994d.png

Also you do not need to use a Label e.g. Picture of SourceCitation can be used instead. 

And maybe choose a photo without spaces in its name  Hehe

But now I also have to tell you about a more serious problem with your report.  It would appear that the file Scripts\script.js in the Report skin template that you use to generate this report is corrupted and so the icon buttons in the header do not work.  

I really really think you should switch to using the Narrative Report skin template in GenoPro 2018.  I no longer maintain the Report templates for GenoPro 2011






'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Friday, March 22, 2019 by genome


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse