GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Author Checked for update, says there was and I downloaded it.
Posted Wednesday, January 15, 2020 - Post #40241
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Monday, June 8, 2020
Posts: 6, Visits: 11
Now it is complaining that I need something with Google Maps. I read the explanation that was offered as a solution, however, I understood none of what was directed to do.

How can I delete GenoPro from my aging Win 7 computer, find the previous version of GenoPro, and download that? 

I am using this Win 7 computer just for GenoPro. My main device is a Chromebook and GenoPro does not work on Chromebooks. Right now all I do on the Win 7 machine is an update with various birth's and death's then create the web version of the Family Tree. With this new glitch, I am unable to create a web-published tree.

I need your guidance. Or better still, an update that carries the dreaded Google Maps API (whatever that is), so it is a clean update, not something that requires me to learn a whole new computer knowledge base.
Posted Friday, January 17, 2020 - Post #40244
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 2,930, Visits: 21,480
Unfortunately Google in its wisdom decided to change its policy on the use of the Javascript Google Maps API.  It now demands that publishers of web pages using this API acquire a key from Google and activate billing on the the usage of that key.  If this is not done the the map do not function correctly.

Reverting to an earlier version of GenoPro with an earlier version of the Narrative Report WILL NOT CHANGE THIS!  An older version will have less bug fixes but will still not generate usable Google Maps in the Narrative Report.  

The message regarding the need for an API key is there to make users aware of the situation.  It does not stop the Narrative Report from being generated.  

I you do not have a Google Maps API key then you can turn off the production of Google Maps in the report by unchecking the option under the Google Maps tab of the Configuration Parameters dialogue.

I agree the process of obtaining a key from Google is convoluted and not easily followed.  Unfortunately I cannot assist with this.  I have do my best to give guidance. If others can give further guidance please do so, alternatively if you have any IT specialist as either familyor  friends they may be able to help


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Friday, January 17, 2020 - Post #40245
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Monday, June 8, 2020
Posts: 6, Visits: 11
Sorry, but I cannot figure out what you are saying. Further, the link to options you provided in your response displays a window similar, but not exactly what your displays. Mine looks like this:http://support.genopro.com/Uploads/Images/7c228b33-ea9e-42ec-b861-03ff.png

You also write "I you do not have a Google Maps API key then you can turn off the production of Google Maps in the report by unchecking the option under the Google Maps tab of the Configuration Parameters dialogue."

BUT, what I actually need is a link to the Configuration Parameters Dialogue so I can uncheck the Google Maps option. I have searched every menu item I can find and there is not a Configuration Parameters dialogue tab or menu item.

Perhaps it is possible the difference in the screenshot I attached is because I am using Win 7, but nonetheless, I cannot see anything that references either a Configuration Parameters dialogue or Google Maps. There are plenty of Geno Maps references, am I simply misunderstanding?

When my desktop Windows computer died, I replace it with Chrome appliances. GenoPro does not work with a browser so I had to buy a windows machine. Since I only need it for GenoPro, I found a used Dell Latitude 2100 laptop. I spent close to $200.00 but wanted to keep the Family Tree alive. The Dell machine is not robust enough to get the Win 10 upgrade. So, if I want to keep the tree alive, I have to buy yet another computer. If that is what I have to do, then that is what I will do. But, even if I do all that, the instructions you provided via the Options link are not clear enough to find the Configuration Parameters dialogue mentioned. I am reluctant to spend $200 again if the problem is not caused by a Win 7 machine.

Posted Friday, January 17, 2020 - Post #40246
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 2,930, Visits: 21,480
By Çonfiguration Parameters dialogue' I mean the parameter settings dialogue that should appear when you launch the Narrative Report dialogue

http://support.genopro.com/Uploads/Images/1fd8762f-763d-4ed8-8954-f4af.png


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Saturday, January 18, 2020 - Post #40249
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Monday, June 8, 2020
Posts: 6, Visits: 11
Yes, thank you. I was able to follow those screenshots and that suggested revision worked. I was able to produce the updated web-published tree.

I did notice something that was not quite right. Two men, Charlie and Joseph died within a couple of months of each other. When I view Charlie's name in the Person Index, it shows his DOB and DOD. When I view Joseph it only shows DOB.

In the actual tree, both Charlie and Joseph have Deceased Crosses in their squares. When I look at Joseph on the Win 7 computer, his DOD, 1/12/2020, is shown within the Properties dialogue box.

Any idea what might cause this? I entered both DOD's at the same time. Generated the report and find Joseph with an empty data cell.

Is there some checkbox that should have been checked or unchecked and wasn't, just for Joseph?

http://support.genopro.com/Uploads/Images/b98fdc4e-3529-41c9-8230-abba.png
http://support.genopro.com/Uploads/Images/ed75aa6a-badd-41cf-9942-b31b.png
http://support.genopro.com/Uploads/Images/b0805baf-748f-42e4-99af-157d.png
Posted Saturday, January 18, 2020 - Post #40250
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 2,930, Visits: 21,480
I see the correct page for Joseph, so it would appear that you are seeing an earlier cached page.  If you clear your browser cache you should see the updated page.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Saturday, January 18, 2020 - Post #40251
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Monday, June 8, 2020
Posts: 6, Visits: 11
Thanks, that fixed it. 

I must say that makes absolutely no sense to me. Both Charlie and Joseph both got into the family tree probably 7-8 years ago. Nothing was changed to either of them until earlier this week. Both of them died within 2 months of each other. I entered their DOD on the very same day. I then made the web-published report. What is confusing, is that Charlie's web page was correct, Joseph's was not. I cannot fathom how the cache had anything to do with Joseph's DOD not appearing. I would understand how the cache would be involved if both Charlie and Joseph's data was misreported.
Posted Sunday, January 19, 2020 - Post #40252
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 2,930, Visits: 21,480
Pages are cached by your browser when they are accessed i.e. when downloaded, not when they are published. I suggest that in your case you accessed Joseph’s page from your web browser before the revision was published and not Charlie’s, hence only Joseph’s page was in the cache. 


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse