GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




<Position IsHidden="Y"/>

Click to view RSS...
Author What is this hiding?
Posted Sunday, April 10, 2022 - Post #42131
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 16 minutes ago
Posts: 437, Visits: 2,896
One of my tools that processes genograms in XML format had a problem with the following code

<PedigreeLink PedigreeLink="Parent" Family="fam01684">
  <Position IsHidden="Y"/>
</PedigreeLink>


Any idea what the object is that is hidden?  The family representation looks normal in GenoPro.
I have no idea how this ended up in my genogram.

Tags:
XML
Posted Monday, April 11, 2022 - Post #42133
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Sunday, July 3, 2022
Posts: 3,177, Visits: 23,408
A 'PedigreeLink' is marked as hidden when the family is on one GenoMap and the individual is on another.  e.g. moving a parent to another genomap and then deleting the parent individual from the original GenoMap transfers the link to the hyperlinked parent Individual but will result in a PedigreeLink with the <Position IsHidden="Y"/> tag because it cannot be displayed.  BUT it should still have the 'Individual' attribute with the ID of the parent.  

I have no idea how you have ended up with a PedigreeLink without an Individual attribute Unsure


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Monday, April 11, 2022 by genome


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse