GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Error at line 182, position 12 (Code/Util.vbs) generating...

Click to view RSS...
Author
Posted Sunday, June 19, 2022 - Post #42274
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 7:21 PM
Posts: 229, Visits: 1,451
Publishing report to https://familytrees.genopro.com/Niko/IZ17855/
  Connecting to server familytrees.genopro.com...
Cloning document I_BY45676...
Opening configuration file Config.xml for skin '\{EN} Narrative Report\*  (2020.03.13)'...
Loading Dictionary.xml...
[0.00] Processing template 'bootstrap.vbs'...
[0.10] Processing template 'Code\init.htm'...
Using 'Common\Code' scripts version 2021.03.20 
Report Language code 'EN' Dictionary version '2020.03.13'
To disable display of parameter settings, tick the box under 'Options' tab of 'Generate Report' dialog.
Title Missing! Click on the "Document" tab to set a title to your genealogy report.
Checking thumbnails status
[65.25] Processing template 'Code\style.css'...
Applying theme 'BlueDNA_3'
Copying files from selected theme
[119.04] Processing template 'Code\header.htm'...
[119.07] Processing template 'Code\footer.htm'...
[119.09] Processing template 'Code\cover.htm'...
[119.10] Processing template 'Code\introduction.htm'...
[119.12] Processing template 'Code\toc.xsl'...
[119.14] Processing template 'Code\index.html'...
[119.50] Processing template 'Code\default.htm'...
[119.89] Processing template 'Code\toc_individuals.htm'...
[120.39] Processing template 'Code\toc_families.htm'...
[120.75] Processing template 'Code\toc_charts.htm'...
[121.14] Processing template 'Code\toc_contacts.htm'...
[121.53] Processing template 'Code\toc_places.htm'...
[121.92] Processing template 'Code\toc_sources.htm'...
[122.32] Processing template 'Code\toc_names.htm'...
[122.71] Processing template 'Code\genomap.svg'...
[122.84] Processing template 'Code\genomap.htm'...
[124.43] Processing template 'Code\toc_genomaps.htm'...
[124.81] Processing template 'Code\home.htm'...
[125.25] Processing template 'Code\heading.htm'...
[125.65] Processing template 'Code\calendar.htm'...
[126.04] Processing template 'Code\calendarevents.js'...
[126.43] Processing template 'Code\timeline.htm'...
Error at line 182, position 12 (Code/Util.vbs) generating 'timeline.htm': Invalid procedure call or argument: 'Left'
Microsoft VBScript runtime error 800A0005




Did a quick search, and saw the fix for this error code at Line 67 is to use the latest Narrative Report.  I'm pretty sure I have the latest set of skins, and my error is at line 182.

Not sure if the error is due to me using a bunch of BCE dates in the genomap?
Posted Monday, June 20, 2022 - Post #42277
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 8 minutes ago
Posts: 3,173, Visits: 23,401
Yes BC/BCE dates are causing this issue.  It was many years ago that I added some code to attempt to deal with BC dates but appears not to be working now (maybe never worked ?) . Also code only caters for dates with up to 4 digit years i.e. +/- 9999.

I will look at the code so see if I can get BCE dates to be recognised correctly and allow for years of any number of digits. 
 
The code is required in order to sort dates into chronological order for the timeline.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Monday, June 20, 2022 - Post #42279
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 7:21 PM
Posts: 229, Visits: 1,451
Thank you for the quick reply.

I had created a GedCom file with no errors, and imported it into Brad F Lyon's Exploring Family Trees tool: https://learnforeverlearn.com/ancestors/

I noticed all the data from 1000 BCE moving forward was displayed correctly, and the previous data points were all bunch together.  I figured the issue was either due to the GedCom standard or some issue with his tool.

Here's what I put entered for the first 6 data points:
http://support.genopro.com/Uploads/Images/f8b6c87b-01cf-4ff9-b44b-6a40.PNG


And here's what it ended up being after I imported it into the other tool:
http://support.genopro.com/Uploads/Images/86b4d90c-673b-4c68-9266-5716.PNG




The dates for Data Points 27 and 28 are correct (920 and 150 BCE).  Birth Dates for Data Points 22 through 26 seemed to jump around randomly (?), and Birth Dates for Data Points 21 down to 1 seemed to subtract 20 years each :
http://support.genopro.com/Uploads/Images/578cbddf-e05c-49ef-9d0b-29e4.PNG


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse