GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Discussion regarding updates to Report Skin Templates since GenoPro...

Click to view RSS...
Author
Posted Friday, July 10, 2020 - Post #40617
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.1.0.1

Last Login: 2 days ago @ 12:07 PM
Posts: 209, Visits: 3,128
I tried the new skin.
Everything seems correct.
One problem:
For any chosen theme, the "banner.jpg" image and some corners is always that of the "Default" theme.
Greetings.

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"


Prova-new-skin.jpg (11 views, 116.84 KB)
Posted Saturday, July 11, 2020 - Post #40619
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 12:21 PM
Posts: 2,941, Visits: 21,543
I seem to recall that this was an issue a few years back.  But I cannot reproduce your result with the current revision.

Can you check that the Report Log looks something like 

http://support.genopro.com/Uploads/Images/3d3c6e53-89d7-41af-a239-a62c.jpg


just to ensure we are running the same scripts


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Saturday, July 11, 2020 - Post #40626
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.1.0.1

Last Login: 2 days ago @ 12:07 PM
Posts: 209, Visits: 3,128
This is the result of the elaboration 
- with \{EN} Narrative Report\*  (2020.03.13)' (with \{IT} Report* it's the same problem) : 
https://familytrees.genopro.com/vlepore/Test/default.htm

And that's the Report log:

Connecting to server familytrees.genopro.com...
Cloning document Cigain...
Opening configuration file Config.xml for skin '\{EN} Narrative Report\*  (2020.03.13)'...
Loading Dictionary.xml...
[0.00] Processing template 'bootstrap.vbs'...
[1.29] Processing template 'Code\init.htm'...
Using 'Common\Code' scripts version 2020.07.05
  **** with modifications **** 
Report Language code 'EN' Dictionary version '2020.03.13'
To disable display of parameter settings, tick the box under 'Options' tab of 'Generate Report' dialog.
Checking thumbnails status
[12.09] Processing template 'Code\style.css'...
Applying theme 'GreenLeaf_2'
Copying files from default theme
Copying files from selected theme
[12.15] Processing template 'Code\header.htm'...
[12.15] Processing template 'Code\footer.htm'...
[12.17] Processing template 'Code\cover.htm'...
[12.18] Processing template 'Code\introduction.
-----
---

In folders .. Commom\Code\Narrative Report\themes and
in folders  ..\{IT} Report HTML\Code\NarrativeReport\themes, all the themes folders are right and also the Banner.jpg images of the various themes are right.

Have a nice weekend!

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"


Edited: Saturday, July 11, 2020 by vlepore
Posted Saturday, July 11, 2020 - Post #40627
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 6:02 AM
Posts: 18, Visits: 740
I have that bug, too. 
The error occurs in themes 3, 7 and 9. 
Posted Sunday, July 12, 2020 - Post #40630
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 12:21 PM
Posts: 2,941, Visits: 21,543
Ok I have given up trying to understand why copying of theme image files works sometimes for some people but not for others. 

I have taken a more pragmatic approach so instead to trying to copy themed images over the top of the default ones I have just added the remaining default images to each of the themes images folders so then there is only one set of images to copy from a single folder. Don't know why I didn't do this originally as the extra space taken up is minimal. 

The attached zip of the Common folder implements this. Unzip into your GenoPro skins folder to replace the existing one.

Let me know if this works.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Common 2020.07.13.zip (7 views, 2.43 MB)
Posted Monday, July 13, 2020 - Post #40633
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.1.0.1

Last Login: 2 days ago @ 12:07 PM
Posts: 209, Visits: 3,128
Unfortunately it doesn't work!
I canceled yesterday's Narrative Report.
I replaced the new Common folder.
I have redone the Narrative Report.

The images sent in the folder: https://familytrees.genopro.com/vlepore/Test/images/banner.jpg
(and also the 4 curvycorner_tl.png, curvycorner_tr.png, curvycorner_bl.png, curvycorner_bl.png) are those of the "default" theme.

Only in the AcornOliveTeal theme, (which is built differently) does not have the problem of the curvycorner_xx images because it uses roundedcornr_grad.gif and roundedcornr_xx.gif, but banner.jpg is always the default theme.
Greetings.

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"
Posted Monday, July 13, 2020 - Post #40634
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 6:02 AM
Posts: 18, Visits: 740

Es muss etwas damitzutun haben was im GenoPro-Speicher vorhanden ist.

Ich hab mal 20Speicherschritte gemacht….. Mal wird es richtig mal falsch gemacht. Nach einemDefault-Thema (1&2) wird auch das nächste Thema richtig gerechnet!


Schritt 1   Thema 1    Thema anwenden 'Default_2' ok

Schritt 2   Thema 2    Thema anwenden 'Default_3' ok

Schritt 3   Thema 3    Thema anwenden 'AcornOliveTeal_2'                ok

Schritt 4   Thema 4    Thema anwenden 'AcornOliveTeal_3'  f             fehler

  zurück zu Thema 3

Schritt 5   Thema 3     Thema anwenden 'AcornOliveTeal_2'               fehler

   nochmal zurück zu zu Thema 2

Schritt 6   Thema 2 Thema anwenden 'Default_3'                            ok

Schritt 7    Thema 3 Thema anwenden 'AcornOliveTeal_2'              ok

Schritt 8    Thema 4 Thema anwenden 'AcornOliveTeal_3'             fehler

            nochmal zurück zu zu Thema 2 

Schritt 9    Thema 2  Thema anwenden 'Default_3' ok

Schritt 10  Thema 4  Thema anwenden 'AcornOliveTeal_3'            ok

Schritt 11  Thema 5   Thema anwenden 'Blood_3' ok

Schritt 11  Thema 6   Thema anwenden 'BlueDNA_3' ok

Schritt 12  Thema 7   Thema anwenden 'GreenLeaf_2' ok

Schritt 13  Thema 8    Thema anwenden 'GreenLeaf_3' fehler

Schritt 14  Thema 9    Thema anwenden 'OliveBranch_2' ok

Schritt 15  Thema 10    Thema anwenden 'OliveBranch_3' fehler

Schritt 16  Thema 11    Thema anwenden 'RoseTint_3' ok

Schritt 17  Thema 8    Thema anwenden 'GreenLeaf_3' ok

Schritt 18  Thema 10    Thema anwenden 'OliveBranch_3' ok

Schritt 19   Thema 2    Thema anwenden 'Default_3' ok

Schritt 20   Thema 4    Thema anwenden 'AcornOliveTeal_3'           ok

Posted Monday, July 13, 2020 - Post #40635
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 6:02 AM
Posts: 18, Visits: 740

In den „Deutschen Skin“ gibt es noch ein paar Probleme!

Hier das 1.

Die „FROM“  „TO“Übersetzung wird nicht gemacht im „ExporttoGedcom“ Skin .

Ich konnte dies nur ändern, indem ich die Gedcom.jsbearbeitet habe, was ich ungern gemacht habe.


Eintrag gerechnetmit Original Gedcom.js in XXX.ged Datei

 

2 CAUS wurdepensioniert

1 EDUCMaschinenschlosser

2 DATE FROM 01 Apr. 1960 TO 30Sep. 1963

2 ADDR in derLehrwerkstatt der Bayer AG

1 OBJE @pic01180@

 

---------------------------------------------------------------------------------------------------------

 

Einträge inDictionary.xml

 

<FmtUntil>&#32;BIS{1}</FmtUntil>        <!-- eg:"Daniel was a student until 1999" -->

<FmtFromTo>&#32;VON{0} BIS {1}</FmtFromTo>        <!--eg: "Daniel worked at Microsoft from 1994 to 1998" -->

</FmtDateRange>

<FmtTimeSpan>

 

---------------------------------------------------------------------------------------------------------

 

Original Gedcom.js

 

return 'FROM '+dateStart+' TO'+dateEnd;

 

---------------------------------------------------------------------------------------------------------

 

geänderte Gedcom.js

 

// return 'FROM'+dateStart+' TO '+dateEnd;

return 'von '+dateStart+' bis'+dateEnd;

 

---------------------------------------------------------------------------------------------------------

Eintrag gerechnetmit geänderter Gedcom.js in XXX.ged Datei

 

2 CAUS wurdepensioniert

1 EDUCMaschinenschlosser

2 DATE von 01 Apr. 1960 bis 30Sep. 1963

2 ADDR in derLehrwerkstatt der Bayer AG

1 OBJE @pic01180@


Posted Tuesday, July 14, 2020 - Post #40637
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 12:21 PM
Posts: 2,941, Visits: 21,543
Translating FROM and TO in the GEDCOM output is not valid as it would not adher to the Gedcom syntax.  Gedcom has only english tags. 

Die Übersetzung von FROM und TO in der GEDCOM-Ausgabe ist ungültig, da sie nicht der Gedcom-Syntax entspricht. Gedcom hat nur englische Tags.

see http://wiki-de.genealogy.net/GEDCOM/DATE-Tag#Zeit-Dauer


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Tuesday, July 14, 2020 - Post #40638
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.1.0.1

Last Login: 2 days ago @ 12:07 PM
Posts: 209, Visits: 3,128
For the themes, I have tried all cases but, as far as I can see, the situation is not accidental or random.
Only with themes 1 and 2 (Default) is the result correct.
With all other themes, the error is always present, even if the cache is cleared at each test.

If you look in the .../images folder of the Narrative Report, you can see that "banner.jpg" is always that of the "Default" theme.

An oddity: if you choose the AcornOliveTeal theme, are transferred to the /images folder of the Narrative Report, the "Rounded*.gif" images of AcornOliveTeal  and the banner.jpg image of the "Default" theme.

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse