GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Gedcom update(?) after Genopro2016 2.9.0.7

Click to view RSS...
Author The report skin exporting to Gedcom no longer works
Posted Tuesday, July 28, 2015 - Post #35308
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Received attached error messages after trying an older Gedcom version(worked until Genopro2016 2.9.06)

gedcom_export.jpg (56 views, 61.66 KB)

Edited: Wednesday, July 29, 2015 by GenoProSupport
Posted Wednesday, July 29, 2015 - Post #35309
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
Important Contributors
Translator
GenoPro version: 3.1.0.1

Last Login: 2 days ago @ 7:02 AM
Posts: 211, Visits: 3,275
I think you should use "{EN} Export to Gedcom \ * (2015.07.07)", present in the GenoPro2016 installation package.
I tried it and it works.

Vittorino Lepore 
"
Se non porti almeno una soluzione, anche tu fai parte del problema" or "If you don't bring at least a solution, even you're a part of the problem"
Posted Wednesday, July 29, 2015 - Post #35315
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Thanks! My eyes must have been tired not seeing this report.
Posted Wednesday, July 29, 2015 - Post #35317
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Yesterday @ 5:07 PM
Posts: 4,630, Visits: 22,318
Should I remove one of the built-in skin?  For GenoPro 2016, there are two types of skins: in-memory and file-based.  Most of the skins are now file-based, however there remains some which are in-memory.
Posted Wednesday, July 29, 2015 - Post #35318
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
I leave it up to you and Ron where to put the templates(skins). I have to think where to put my own skins(DE, JA,etc.), away from the standard ones.

Why is it that even after using the "Eport Gedcom" version as proposed I am still getting
 the same error message: any plausible answer is welcome.
Base skin version 2015.02.01

[814.20] 72y 11m 5d
[814.23] The tag 'Family.Marriage.civil.date' is no longer valid.  Try 'Family.Marriages(0).Date'
[814.24] The tag 'Family.separation.date' is no longer valid.  Try 'Family.Marriages(0).Divorce.Date'
[814.28] The tag 'Family.Divorce.date' is no longer valid.  Try 'Family.Marriages(0).Divorce.Date'
[826.35] The tag 'Education.Start.Date' is no longer valid.  Try 'Education.DateStart'
[826.45] The tag 'Education.End.Date' is no longer valid.  Try 'Education.DateEnd'
[826.45] The tag 'Occupation.Start.Date' is no longer valid.  Try 'Occupation.DateStart'
[826.46] The tag 'Occupation.End.Date' is no longer valid.  Try 'Occupation.DateEnd'
[826.64] The tag 'Contact.Start.Date' is no longer valid.  Try 'Contact.DateStart'
[826.64] The tag 'Contact.End.Date' is no longer valid.  Try 'Contact.DateEnd'


Edited: Thursday, July 30, 2015 by maru-san
Posted Thursday, July 30, 2015 - Post #35321
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 3,089, Visits: 22,454
I have no real plausible answer to your issue with the ' {EN}Export to Gedcom' skin, unless you have inadvertently copied a very old gedcom.js file into it, overwriting the installed copy.  I am sure the tag changes were from a very long time ago. Re-installing GenoPro 2016 should correct that situation. 

You own skins should be safe under the same skins folder as that used by the GenoPro installer, provided that the folder names for your own skins are different from the ones installed by GenoPro. But of course it is always wise to keep backup copies!





'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Sunday, October 4, 2015 - Post #35838
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Tuesday, February 11, 2020
Posts: 21, Visits: 90
I have a similar problem. The program doesn't export to Gedcom, giving this error.

http://support.genopro.com/Uploads/Images/85373be4-8479-45dc-9542-c6f5.jpg
Posted Monday, October 5, 2015 - Post #35840
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 2 hours ago
Posts: 3,089, Visits: 22,454
This bug has been lurking for a very long time and is triggered when you attempt to exclude foster and adopted children from the gedcom by unsetting this option.  I could reproduce this error using the HP sample it is just surprising it has only surfaced now.

Attached is a revised Gedcom.js script that you can drop into your Export to Gedcom skin in place of the original that should fix this problem.

Please report back on success or otherwise and if it works I'll get it included in the next GenoPro update.

Sorry maru-san still no joy with your issue. I have checked my scripts again and cannot find any source for these messages which only confirms that they come from within GenoPro.exe and not the skin.  I think the fact that the messages are prefixed with the cpu time indicates this fact as well. Strangely an 'age' or time duration is output before the messages e.g. 90y 9m 18d. Does it only occur on selected .gno files? If so perhaps they have some old tags in one or two records.

Dan could you please look into why these messages are produced?


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Gedcom.js (37 views, 40.65 KB)
Posted Monday, October 5, 2015 - Post #35841
Junior Member

Junior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior MemberJunior Member

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: Tuesday, February 11, 2020
Posts: 21, Visits: 90
Thanks.
It works now.


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse