GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Scroll Bar Position

Click to view RSS...
Author When scrolling through the search results, the scroll bar auto-resets to top regardless of position in list
Posted Tuesday, January 19, 2016 - Post #36543
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Gamma
GenoPro version: 3.0.1.4

Last Login: Wednesday, November 24, 2021
Posts: 249, Visits: 781
I'm not sure if this is a general bug in GenoPro or something specific to my installation, but I'm hoping this has been fixed in GenoPro 2016, or that it will be in the rebuild for GenoPro X. I thought I had reported it before, but my searches are coming up empty.

When I'm looking at the search results and using the mouse to drag the scroll bar down, when I release the mouse button, the scroll bar resets to the home (top) position but the list window display keeps my position. This doesn't happen in the regular list view.

If anybody else can replicate this bug, please comment.

Just in case it is something hardware or OS specific, I'm running Windows 7 Home Premium on an Intel i5-3450 system with 16GB of RAM.


GenoPro: Best. Genealogy. Software. Ever.

Tags:
Posted Tuesday, January 19, 2016 - Post #36545
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Today @ 4:42 AM
Posts: 4,731, Visits: 22,500
I get this behavior on Windows 7 but only when the mouse is too far away from the scroll bar, otherwise the scroll bar behave as expected.  Do you get the same result on your machine?
Posted Wednesday, January 20, 2016 - Post #36550
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Gamma
GenoPro version: 3.0.1.4

Last Login: Wednesday, November 24, 2021
Posts: 249, Visits: 781
No, the position of the mouse relative to the scroll bar is irrelevant; as soon as I release the mouse button when dragging the scroll bar down, the scroll bar jumps back up to the top, but the display remains scrolled down until I click in the scroll bar again, when it immediately resets to the top. The horizontal scroll bar behaves in the same way, resetting to the left instantly when the mouse button is released but leaving the visible columns until the scroll bar is clicked again.

Even more strange, which I just noticed now switching back to GenoPro from the browser window: When the window loses focus, the scroll bars are set to where they should be for the column display (to the far right horizontally in my current case) and then it resets to the right when I drag it to the left. Screen shots attached.

And now things have reached another level of strange. When I went back to GenoPro to take my screenshots, restoring focus to the same search results window for the third time, the scroll bars are now working normally. Maybe this in itself will help track down the problem, but I'll provide a screen shot anyway.

Okay... here's the screenshot (cropped to the search results window), and things continued to behave strangely. This time, the scroll bars worked normally after the search results window lost and regained focus once. When the image was taken, the search results window was scrolled to the far right (as you can tell from the column positions) and the bottom (which may not be as obvious)... but note the positions of the scroll bars.

http://support.genopro.com/Uploads/Images/ec7e31e9-ccfc-4eb1-802b-a30d.jpg


GenoPro: Best. Genealogy. Software. Ever.

Edited: Wednesday, January 20, 2016 by Jakk
Posted Friday, January 29, 2016 - Post #36626
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Gamma
GenoPro version: 3.0.1.4

Last Login: Wednesday, November 24, 2021
Posts: 249, Visits: 781
Has anyone else noticed this sort of behaviour in the Problem Spotter window? I've been seeing it there since my recent upgrade to 2016, but only after I've had GenoPro running for a while. I've already mentioned it to Dan via email in our exchange regarding the original issue (which seems to have been fixed now; many thanks!). Hopefully this is an equally easy fix, and isn't a side effect of the previous fix. Whistling




GenoPro: Best. Genealogy. Software. Ever.


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse