GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Crash displaying Japanese text

Click to view RSS...
Author Crash displaying Japanese text
Posted Monday, June 6, 2005 - Post #6519
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Gee. This is not good. GenoPro should not crash under any condition. Can you please send me a sample file (or a scenario) where such a crash occurs. I will fix this bug too. Any crashing bug I can reproduce on my machine will be fixed. No mercy on bugs.


Was able to reproduce this bug as follows:
display shows only alternative (jap) name, changed to alternativename(jap)-lastname(en), from tried to input firstname(en), however with space first. After hitting space receive following message
"Genopro has caused an error in MFC42.DLL. Genopro will now close.

This crash will not happen on other scenarios,i.e. not when there is no hyphen between the names.

I miss in the display option: alternativename_lastname_firstname. Have asked for this one once before.
Posted Thursday, August 18, 2005 - Post #6520
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Moderators
Customers
Gamma
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Monday, October 4, 2021
Posts: 4,654, Visits: 22,352
maru-san, I moved your post to a separate topic so we can resolve this bug.

If I remember, you are using Windows Millenium. I don't have Windows ME; only Windows 98 English edition. Can you tell me if this bug occurs under Windows 2000 or XP? I suspect this bug is related to the "Unicode Layer" I wrote to simulate Unicode under Windows 95/98/ME. In any regards, I plan to fix the bug. If you can send me a .gno file with the exact name, I will do the test myself on my machine.

I miss in the display option: alternativename_lastname_firstname

Do you want them with the underscore, or all together. The format I am thinking is "%A%L%F", but you may prefer "%A-%L-%F" or "%A %L %F". Do you want the middle name too?
Posted Thursday, August 18, 2005 - Post #6521
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Mailed the file.


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse