GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Discussion re XML Toolkit for GenoPro

Click to view RSS...
Author Q&A
Posted Saturday, February 10, 2007 - Post #16307
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 1:41 PM
Posts: 2,520, Visits: 17,931
Update 2013.08.05  See topic XML Toolkit for GenoPro for latest skin

At last I have a beta(gamma?) version of the Toolkit running as a Javascript skin under the Report Generator.It will add marriage/divorce dates to the family label, create multi-line custom tags, specifically aimed at use as the top display label for individuals.  The templates for these tags can be modified via Dictionary.xml. Note that although multi-line custom tags can be displayed as the top label for an individual, such tags cannot be modified within GenoPro.There is an option to mark as dead anyone over a specified age. Also a number of options aimed at recovering Gedcom data languishing in Custom Tags after a Gedcom import.

See the front of file toolkit.js to see documentation on options or see the options selection form below.

To install unpack the attached zip into a folder named 'XML Toolkit' under your GenoPro 'skin' folder. It should then appear in the list of skins in the GenoPro Report Generator.

I have done limited testing but it has yet to be exposed 'in the wild' so use with caution. It produces a GenoPro compatible XML file with the changes in the specified Report folder. I recommend comparing the before an after XML files to check changes. First export your existing .gno file to an XML to serve as the reference. Run this utility and open the XML file produced with GenoPro. Check that it loads with no errors and visually verify the changes using GenoPro. Then export this new file as another new XML file (this will provide your data in the same format as your reference XML file). Then compare the reference XML file with this latter file with a utility such as WinMerge or WinDiff. (Google will find downloads for these if reqd). If you are happy with the changes you can then save the new XML file as a .gno file. Play safe a keep a backup of the original.

http://support.genopro.com/Uploads/Images/d1b5e934-1db6-43dd-b87f-2a0f.png


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Monday, August 05, 2013 by genome
Posted Sunday, February 11, 2007 - Post #16317
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 1:41 PM
Posts: 2,520, Visits: 17,931
Sorry Iain, I think I changed the code in this area and forgot to retest it. I have attached a revision to my original post below (or above, depending on your forum control panel settings!)

I have taken the opportunity to revise the code to add birth comments detailing the particular religious event if it does not match those catered for by GenoPro. e.g. Blessing, First Communion, Bar-Mitzvah etc..


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Monday, February 12, 2007 - Post #16331
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.0.2

Last Login: Thursday, October 05, 2017
Posts: 365, Visits: 3,663
Hi Ron,

I downloaded your new version of the js and replaced the one on the XMLtools skin with it but now get this error

Generating report to 'C:\Family Trees 2007\2007 New Families\xml test\'
Cloning document xml test tool...
Opening configuration file Config.xml for skin '\XML Toolkit\*'...
Loading dictionary.xml...
[0.00] Processing template 'Toolkit.js'...
Processing 9 Families.....
Processed 9 families
adding 'DisplayText' tags (labels) to 7 of these
Processing 48 individuals...
Error at line 359 (Toolkit.js) : 'length' a la valeur Null ou n'est pas un objet.
Erreur d'exécution Microsoft JScript 800A138F

The line in question is the following

if (strDate.length>3) strDate=strDate.substr(strDate.length-4);

I tried it again without trying to use the census or residence and occupations and it seems to have worked for the marriage lines and DOB s etc.



Edited: Sunday, August 03, 2008 by GenoProSupport
Posted Monday, February 12, 2007 - Post #16332
Grand Master

Grand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.0.7

Last Login: 42 minutes ago
Posts: 1,423, Visits: 24,748
What am I doing wrong? I downloaded Toolkit.js and placed it in a folder Program Files\GenoPro2007\Skins\XML Toolkit but my list of report options is unchanged, ie

Customized English Narrative Report\* (English Narrative Report)
Display All Comments
English Narrative Report
Export to Gedcom
Export to SQL
Save All GenoMaps to Disk

I am guessing the XML folder needs some of the standard files, but will hope for guidance
Posted Monday, February 12, 2007 - Post #16334
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 1:41 PM
Posts: 2,520, Visits: 17,931
appleshaw (2/12/2007)
What am I doing wrong? I downloaded Toolkit.js and placed it in a folder Program Files\GenoPro2007\Skins\XML Toolkit but my list of report options is unchanged

Toolkit.zip contains three files - Config.xml, Dictionary.xml and Toolkit.js. Unzip toolkit.zip and place all three files in the folder 'XML Toolkit' in your skins folder. The Options tab of GenoPro's Generate Report shows where GenoPro looks for skin folders.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Monday, February 12, 2007 by Ron
Posted Monday, February 12, 2007 - Post #16336
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.0.2

Last Login: Thursday, October 05, 2017
Posts: 365, Visits: 3,663
I noticed that the zip 2 only had the js file in it which I had added to the skin folder.

Now I have downloaded the zip 3 with all three files in it and it worked perfectly. Thanks Tongue:

One point, the old system allowed to show the choice of full dates above the marriage line instead of just the year.

Would it be possible to add this option ? Whistling

Posted Monday, February 12, 2007 - Post #16337
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 1:41 PM
Posts: 2,520, Visits: 17,931
IainTait (2/12/2007)

Error at line 359 (Toolkit.js) : 'length' a la valeur Null ou n'est pas un objet.
Erreur d'exécution Microsoft JScript 800A138F
The line in question is the following
if (strDate.length>3) strDate=strDate.substr(strDate.length-4);

Looks like you have a CENS tag without a DATE subtag. I didn't allow for this, a Census entry without a date would not be of much use. Version 2.0.0.b3 has the fix anyway, also a fix to prevent an empty CENS tag being left.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Edited: Wednesday, June 18, 2008 by GenoProSupport
Posted Monday, February 12, 2007 - Post #16338
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.0.2

Last Login: Thursday, October 05, 2017
Posts: 365, Visits: 3,663
Ron (2/12/2007)

Looks like you have a CENS tag without a DATE subtag. I didn't allow for this, a Census entry without a date would not be of much use. Version 2.0.0.b3 has the fix anyway, also a fix to prevent an empty CENS tag being left.

I had done a second try without the census box ticked and it worked with zip 2. Now with zip 3 all work including the census box, so thanks again ! Tongue:

Edited: Monday, February 12, 2007 by IainTait

Posted Monday, February 12, 2007 - Post #16341
Grand Master

Grand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand MasterGrand Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.0.7

Last Login: 42 minutes ago
Posts: 1,423, Visits: 24,748
Got past stage 1 now but on two files I get

Generating report to 'D:\Data\GenoPro Beta Report\beta2\'
Cloning document RollissonNBI...
Opening configuration file Config.xml for skin '\XML Toolkit\*'...
Loading dictionary.xml...
[0.00] Processing template 'Toolkit.js'...
Error at line 1216 (Toolkit.js) : Automation server can't create object
Microsoft JScript runtime error 800A01AD

Offending line appears to be
oIE = new ActiveXObject("InternetExplorer.Application")

So I assume it is something to do with my setup here. I am using FireFox with the IE Tab loaded, so can not load Internet Explorer directly. Just checked one of the old .vbs utilities, which gets same result, so I have probably solved the first stage of my problem - but others may have the same headache
Posted Monday, February 12, 2007 - Post #16343
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.0

Last Login: Yesterday @ 1:41 PM
Posts: 2,520, Visits: 17,931
appleshaw (2/12/2007)
I am using FireFox with the IE Tab loaded, so can not load Internet Explorer directly.

I don't think having the IETab extension in Firefox should prevent IE from loading separately. I have just installed IETab on my Firefox  and I can still run IE and XML Toolkit. If you cannot load IE standalone this may be part of the problem. 'SearchWinIT.com' gives the following suggestion:


It sounds like the ActiveX components for IE may have become unregistered. Try typing these commands from the command line, in this order:

regsvr32 urlmon.dll
regsvr32 shdocvw.dll
regsvr32 mshtml.dll
regsvr32 browseui.dll
regsvr32 rsabase.dll

Systems with the Microsoft Java VM present, type: regsvr32 msjava.dll




'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse