GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Help request for "Page not found"

Click to view RSS...
Author "Page not found" after exporting to familytree public site
Posted Monday, May 20, 2019 - Post #39879
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Saturday, June 01, 2019
Posts: 6, Visits: 18
http://familytrees.genopro.com/francescomarzolo/Marzolo-family/


Following the link after export, after a flash of the right page I can see only the error "Page not found"

How can find support for the problem fix?
Posted Monday, May 20, 2019 - Post #39880
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Monday, October 14, 2019
Posts: 372, Visits: 2,373
I can open your report without any problem.

What happens at the end of the report generation session.  Does the start page open?


Maybe you could first try to generate the report and send the output to a local folder on your PC.

Posted Monday, May 20, 2019 - Post #39881
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Saturday, June 01, 2019
Posts: 6, Visits: 18
Thank you for the reply

Locally I have no problems.

Yes at the end Genopro ask me to open choosing a web browser.

On the online version, I encounter the same issue on Firefox, Chrome, Brave web browsers.

Strange thing, when I Ctrl-refresh I can see one page fine, but clicking a link or closing and reopening browser the "Page not found" reappears.

Edited: Monday, May 20, 2019 by francescomarzolo
Posted Monday, May 20, 2019 - Post #39882
Famous Writer

Famous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous WriterFamous Writer

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Monday, October 14, 2019
Posts: 372, Visits: 2,373
If you are being asked to choose a web browser, you probably don't have a specific browser set as default.  You could try declaring e.g. Firefox as the default browser (I managed to open your report with Firefox).

What happens if you open someone else's tree?  See http://familytrees.genopro.com/

Posted Monday, May 20, 2019 - Post #39883
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Saturday, June 01, 2019
Posts: 6, Visits: 18
Many do the same behavior, I have tried with Firefox and Chrome






Posted Thursday, May 30, 2019 - Post #39901
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: 2 hours ago
Posts: 2,830, Visits: 20,657
I have been investigating this problem.  The report pages all appear to load correctly when using the hyperlinks in the report's index pages and detail pages.  However I did discover a problem if you try to open an individual's detail page directly from the browser address bar or say from a link in a goggle search

e.g.
       familytrees.genopro.com/francescomarzolo/Marzolo-family/Bertinelli-Enrico-ind00047.htm

I think I have a fix for this and have attached a revised version of the script.js file to replace that in your GenoPro skins folder under Narrative Common\Code\scripts

You will need to regenerate your report to test this.

Hopefully this fix will be incorporated into GenoPro soon.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


script.js (6 views, 60.09 KB)
Posted Friday, May 31, 2019 - Post #39903
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

Customers
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.4

Last Login: Saturday, June 01, 2019
Posts: 6, Visits: 18
I'm very sorry, but the URL personal direct problem as you report is not the case.
Using three different browser in my PC, (Firefox, Chrome, Brave) the behavior is that putting direct the follwing string in address bar
http://familytrees.genopro.com/francescomarzolo/Marzolo-family/

i get "Page not found" problem. Please note, I have just removed history and all saved data for genopro sites.

Only Internet Explorer is running fine.
I have saved the new version script, rebuilt, and published the new report, but the problem still remain.

If you like and need to do same debug, I can use same debug tool that you may suggest, and I will be happy to send you the debug data produced.
I am not a javascript and front end expert , but I am a VB, Rust, Python and Java programmer, so no problem to help you.
Thank you very much


Posted Friday, May 31, 2019 - Post #39904
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: 2 hours ago
Posts: 2,830, Visits: 20,657
Hmm, not sure what is going on with this one.  I have accessed your report with Chrome, Firefox and IE and all work fine.  Also the problem when using a URL direct to individual's page is now fixed.

This is going to be tricky to debug as there is no html page to examine.  Just wondering if you try the following in Chrome:

Before attempting to load the page, open Chrome Developer Tools by pressing F12, click the Network tab and the 'preserve log' and 'disable cache' options on the line below the menu bar.  Next back in the same Chrome tab from which you pressed F12, try and load your report page.  When you get the Page not Found message go back to the Developer Tools examine the Network log for any clues to the problem such as 404 in the status column.

Update
i may have found the cause of this whilst delving into what happens when the direct URL causes the error.  It would appear something external to the page is sending a message to it, possibly a browser extension?  Try the revised script.js attached please.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


script.js (3 views, 60.11 KB)

Edited: Friday, May 31, 2019 by genome
Posted Tuesday, August 27, 2019 - Post #40054
Forum Newbie

Forum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum NewbieForum Newbie

FamilyTrees.GenoPro.com
Customers
GenoPro version: 3.0.1.5

Last Login: Tuesday, September 10, 2019
Posts: 8, Visits: 39
Dear Master,
I understand that there were couple cases with similar mistake(s), but I ask for help too.
Report generating finishes without messages about mistakes to following directory:
http://familytrees.genopro.com/GOVTVYAN/
When I open this link then I can see following screen of this link:
http://support.genopro.com/Uploads/Images/710e4587-b8fa-4b5c-916c-a1c7.JPG


I opened in Internet Explorer - same result.
I used your script.js, but without success.
Posted Tuesday, August 27, 2019 - Post #40056
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.0.1.5

Last Login: 2 hours ago
Posts: 2,830, Visits: 20,657
I'm afraid that the page bears no resemblance to anything produced by the Narrative Report skin!

Please confirm that you are attempting to produce a Narrative Report and please post a copy of text from the 'Report Log' section of the Generate Report dialog to show the process. 


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse