GenoPro Home
GenoPro Home  |  Get Started With My Genealogy Tree  |  Buy  |  Login  |  Privacy  |  Search  |  Site Map
 

GenoPro Support Forum




Multilanguage report

Click to view RSS...
Author Name.Dictionary not to found in Narrative report
Posted Thursday, March 11, 2021 - Post #41286
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Ron, whether I use english or german narrative report, the name dictionary is not working or can not be found. I placed it next to the Dictionary.xml files. If I make a report all languages are shown, if no selection is made. If I make a selection like DE or EN the report stops since no Name dictionary found.
regards
Posted Friday, March 12, 2021 - Post #41289
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 10 minutes ago
Posts: 3,068, Visits: 22,303
Seems to work OK if I create NameDictionary.xml in {EN} Narrative Report, but inexplicably the default location for NameDictionary.xml in {DE} Familiengeschichte\ConfigMsgLocal.xml has been set to 

Line 513:                         Default="C:\Program Files (x86)\Lang\DEDictionary.xml"  w00t

when it should be 

Line 513:                         Default="NameDictionary.xml"


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"
Posted Friday, March 12, 2021 - Post #41292
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Thanks Ron for this. At least I can make a report, but still have all languages reported. Where is my problem? I did not change a thing over the years.
Posted Saturday, March 13, 2021 - Post #41293
Legendary Master

Legendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary MasterLegendary Master

Administrators
Customers
Important Contributors
FamilyTrees.GenoPro.com
GenoPro version: 3.1.0.1

Last Login: 10 minutes ago
Posts: 3,068, Visits: 22,303
Many, many moons ago (maybe even in a former life Smile  ) I changed the preferred syntax for multilingual fields from {?XX:text}  to {¿XX:text¿} and I think the reason was to allow } within the text.  My scripts should have catered for both variants but I have discovered a coding error which prevented the old version from working correctly.

I believe I have fixed the issue in the attached Common\Code\Util.vbs script.  If you can confirm this then I'll add the correction to my next Skins bundle.


'lego audio video erro ergo disco' or "I read, I listen, I watch, I make mistakes, therefore I learn"


Util.vbs (1 view, 122.85 KB)
Posted Saturday, March 13, 2021 - Post #41294
Forum Master

Forum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum MasterForum Master

Customers
Important Contributors
FamilyTrees.GenoPro.com
Translator
GenoPro version: 3.1.0.1

Last Login: Sunday, March 21, 2021
Posts: 716, Visits: 12,927
Had to try at 10:30 pm. You made it again, it works like it did before. Thanks!


Similar Topics

Click to view RSS...
Expand / Collapse

Reading This Topic

Expand / Collapse